Testing New Website

Tagged: 

  • Creator
    Topic
  • #31203

    This is a test post. Please post any errors or issues in this thread.

Viewing 23 replies - 1 through 23 (of 23 total)
  • Author
    Replies
  • #31506

    Thanks Jacqui and Darren,

    Glad it’s all working fine now. Just one more small issue to resolve that you mentioned in your earlier posts Darren, about getting redirected to “random posts” after you reply to a topic. It seems that since we are now using IIS, the URL rewrite rules do not work the same as they did on the old web server (Apache). After a reply is submitted, it seems to be rewriting the URL and replacing the topic/topic-name part causing strange behaviour to happen!

    If you experience this, don’t worry – your reply has been submitted but you have been taken to a strange page. Usually its just back to the forum home page but sometimes (like in your case Darren) it finds a slight match to an old topic, and takes you there.

    Working on this but seems like we will only be able to resolve it in the new year.

    Merry Christmas everyone and have a happy and safe new year! 🙂

    Ana

    #31505

    Darren
    Participant

    Hi Ana, I can now see my topics in firefox 17. Thanks. Good to see you go the latin1 to utf-8 sorted as well. its nice to see somebody who knows what they are doing looking after the website 😉

    #31495

    Jacqui
    Moderator

    Excellent that we can now see who posted last in each thread… THAT will save a lot of time too.

    Merry Christmas Ana the worker. Have a good holiday break.

    #31474

    Hi Darren,

    Just an update on the site. I have changed the collation on all tables in the database from latin1 to utf-8. Special characters should now not generate a WordPress database error.

    Test: ↑ ↓ 

    #31451

    Hi Darren,

    I have implemented a quick fix to the issue in Firefox that you have been experiencing. Give it a go and let me know if you still have problems.

    Please note that this is a temporary fix and it is ultimately an issue with bbPress that they are currently working on and are planning on fixing – see ticket #2067 in this link: http://bbpdevel.wordpress.com/2012/12/12/were-planning-on-having-our-weekly-dev-chat/

    Thanks

    Ana

    #31396

    Hi Darren,

    I have investigated your issue with not being able to view your topics and replies in Firefox and have found this: http://bbpress.org/forums/topic/profile-topics-or-replies-posts-not-being-displayed/#post-123074

    It seems to be an issue with bbPress but I am still investigating.

    As for your other errors (WordPress database errors), this is due to the process of converting the old bbPress database to the new one packaged as a WordPress plugin. In the old website, the version of WordPress was about 3-4 years old. Back then, the default charset for MySQL was defaulted to Latin encoding. Now-a-days, the most commonly used charset is UTF-8. The tables in the database are still set to Latin encoding since we had not run into any errors leaving this as the default.

    When you copy pasted what you saw you included an arrow that was part of the pagination. This arrow is a UTF-8 character, and when MySQL tried to find a Latin encoding equivalent, the database returned an error since it is not a character it has seen before.

    I have sent you an email regarding testing on our test server if you are interested.

    I am still not fully informed on what you did to generate every single error but this is what I could find given the information. If you could send me some more detail, it would be much appreciated. You can email me directly if you like ( I have already sent you an email ).

    For the meantime, please use a supported browser and I will update this forum when I have found a fix.

    Thanks

    Ana

    #31395

    Darren
    Participant

    Hi Ana, thats what I see with chrome, but with firefox the page is blank.

    It seems I was mistaken, I can post simple text with firefox/ubuntu, but the content of some of my complex posts is generating strange errors. I’ll switch to email.

    thanks Darren

    #31375

    Darren
    Participant

    I cannot post at all using firefox 17.0.1 with ubuntu 12.04

    #31373

    Hi Darren,

    I see 67 Topics and 800 replies created. Can you please elaborate on what you see?

    Thanks

    Ana

    #31372

    Darren
    Participant

    When viewing profile, pages showing “topics created” and “Forum Replies Created”
    eg https://www.monarch.org.nz/forum/users/darreng/topics/

    are blank with Firefox 17.0.1 on WinXPSP3
    works correctly on Chrome 23.0.1271.97 m on WinXPSP3

    #31332

    Terry
    Participant

    I tried it again and again and for some reason I don’t know why, it now it works!

    I am very pleased, and relieved!! Am viewing new website at work on Windows 7 internet explorer 9

    #31331

    Terry
    Participant

    The new forum seems to have a problem as I cannot view my last post on the Yellow Admiral project only the first page from 2010. Therefore I cannot add to it?
    You probably already know about these teething troubles but if not you will now. I have tried logging in which works but it still won’t move off first page of thread.

    There are no recent posts showing on the first page. Also it says 555 posts and am pretty sure it should be 556 as I remember posting no 556 2 days ago. The bottom of page 1 is from over 1 month ago 8th November 2012 and I have posted many times and 2 days ago. It says last post 2 days ago but that is not the post. It looks as though the December posts have been lost in the system. I really should have taken a back up. I usually copy and paste my posts every month back to a word document as I hope to use all the posts to create a new Yellow Admiral breeding document in the future but never got around to backing up December posts before the changes yesterday. I do hope that the last posts for December are still there somewhere on Monarch trust.

    #31327

    Jacqui
    Moderator

    Hi Anna

    Actually, I just put a post in the forum about that – they’re called avatars. Try it out and see if it works. I’ve had my avatar so long I don’t know how I got it started. I have a suspicion that it’s linked to my email address, so if I sign in with that address it somehow finds my avatar. But goodness knows where I’ll go to change it!

    Please let us know how you get on.

    Jacqui

    #31325

    Anna
    Participant

    How do I put a photo by my name like Jacqui and Pepetuna have???

    #31323

    Jacqui
    Moderator

    Hi Sally

    We discussed having the forum posts backwards some months (years?) ago, and from memory the majority thought it would be a good idea. However, I know I’m finding it a little difficult so far to get used to. Give it a week or two and then we can have a “vote” on what we like. I think it’s because the whole look of the forum is so different.

    Ana in her post explained how to start a new topic. https://www.monarch.org.nz/forum/topic/testing-new-website/#post-31271

    #31322

    SallyM
    Participant

    Ubuntu – Version 12.04.1

    Chrome – Version 23.0.1271.97

    Yes, working fine (I think) but I’m not liking the posts going backwards.

    On the forum homepage I get a message saying I cannot create new topics (and nowhere that I can?).

    After I logged in I was redirected to the website homepage (not even just forum home page) rather than the page I was on where I logged in from. Meant having to find my way back here to post.

    Pleased to now have the option of being notified of replies to new comments on posts.

    #31320

    Jacqui
    Moderator

    Using Windows Vista with Mozilla Firefox 17.0.1, works fine.

    #31319

    Jacqui
    Moderator

    If you are reading this and are not having any issues, would you please record in a post:

    Browser (e.g. Mozilla Firefox, Internet Explorer) and version (you can find this under Help or I found the version under Google Chrome (Version 23.0.1271.97 m).

    Also what system you’re running (Windows 95, Windows Version 7, Linux etc).

    We would be grateful!

    #31271

    Hi Pepetuna

    Thank you for your great feedback and suggestions!

    I agree with there not being an easy/obvious way to start a New Topic or Reply. We will add this to our list of improvements once we have gone live and made sure all of the crucial things are working.

    For the meantime, you can add a new topic by scrolling to the bottom (past all of the recent topics) and clicking on which forum you want to add a topic to. Once you are in that forum you can start a new topic but scrolling to the bottom and entering the details. This is the same as how to reply (located at the bottom).

    We have added your suggestions to our list and will consult them with Jacqui at our next meeting.

    Voices refer to how many unique people are present in the conversation. But it seems that during the conversion process, these have been reset to zero. We can surely look into removing this no problem.

    I have tested the forum roles with a plain member role and they can only edit their own posts nothing more.

    Thank you for your great testing and valuable suggestions. Jacqui has given the go for putting it up on live so that should be done in a few hours.

    Thanks

    Ana

    #31235

    Pepetuna
    Participant

    Look and feel acceptable to MBNZT?
    There are a couple of suggestions:

    • The most important one is that it is not at all obvious where you can start a New Topic or Reply to a topic.  Maybe it is there, and I am being blind, but if so, it needs to be really obvious for people to use it easily.
    • Where are the hot tags now? These used to be in a column to the right of the post. They are important.
    • We will need to have some kind of explanation about what Add to favourites and Subscribe mean. When I tested, the topic was added to my profile, but what does this mean? Is an email sent when new posts added?
    • What does 0 Voices mean? Topics all seem to have 0 voices . If this is a feature we are not using, can we get rid of the orphan word?
    • Does everyone else see EDIT CLOSE STICK TO FRONT MERGE TRASH – because I don’t think we want everyone to be able to Trash or Close posts.
    #31234

    Jacqui
    Moderator

    Photos not clickable to enlarge. For instance

    https://www.monarch.org.nz/2012/12/13/photo-of-a-butterfly-5/

    when clicked once it disappears. Click the second time and get same error message as above. 🙁

    #31232

    Jacqui
    Moderator

    Uploading photograph to website via photos@monarch.org.nz, photo showed up okay, clicked to enlarge, okay, clicked again to zoom, got error message:

    500 – Internal server error.

    There is a problem with the resource you are looking for, and it cannot be displayed.

    Teschemakers3

     

    #31204

    This is a test reply. All suggestions are welcome.

Viewing 23 replies - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.